Sandbox not reachable
Resolved
Apr 06 at 07:05pm CEST
Sandbox is reachable again
Affected services
Sandbox
Created
Apr 06 at 06:33pm CEST
What happened
- Sandbox stopped responding at 18:32:36 UTC+00
- Sandbox started responding again at 19:05:30 UTC+00
- All application servers operated normally
- Database servers operated normally
- API was reachable when contacting the server directly from within our VPN
Why this happened
We are protecting our API using Cloudflare's services. Cloudflare had an outage which caused requests to never reach our servers. Cloudflare posted a post-mortem: https://www.cloudflarestatus.com/incidents/g7sp3s3pdx4m.
Estimated costs
- We were down for 19 minutes
- We had increased response time for another 42 minutes after the downtime was resolved
- Production was unaffected (Cloudflare only had a partial outage, and Production/Sandbox used separated routing and accounts everywhere, including Cloudflare)
- Since Sandbox is for testing only, no production integration was affected
How to prevent this in the future
For longer-lasting outages of Cloudflare, we can failover the routing to a backup provider. For short outages, a failover will take too long (updating DNS records takes between a few minutes to several hours).
In general, Cloudflare is a highly reliable provider.
Affected services
Sandbox